CLOSE

GAP Programmer Coder 5.07

9927-2101_B.exe

     

    This Version only supports the Atlas II and Engine platforms. This installation contains:

    • GAP Programmer Coder 5.07-2
    • GAP 5.07 Template
    • OpWgx Libraries
    • GNU support

    The GAP Programmer software tool is designed to support the creation and compiling of GAP applications for use in Woodward product lines.

    Compatibility:

    • This version of the GAP Programmer is only for the Atlas II and Engine platform controls: ECM3, MCU (733, 766, In-Pulse II, ARAPAHOE), PCMHD
    • With this version of GAP Programmer, use GAP Editor 3.06 or higher
    • With this version of GAP Programmer, use Toolkit 4.0 or higher
    • With this version of GAP Programmer, use SOS 4.04 or higher
    • With this version of GAP Programmer, use Control Assistant 4.03 or higher
    • With this version of GAP Programmer, use Windows® XP, Vista or 7

    WARNING:
    If installing an older coder version on a PC with a newer version, it is possible to overwrite the Hex2Scpt.exe file with an older version. This might cause the newer coder version to fail when generating ".scp" files. Newer versions of Hex2Scpt.exe are backward compatible, so this problem can be addressed by re-installing the latest Hex2Scpt.exe file from the Woodward website (use "Hex2Scpt" as the search string) after installing an older version.
    This is a potential issue for coder installations like this one that are not platform-specific and may support controls which use the .scp file format.

    What's new in 5.07-2

    • Support for Atlas II platform, including
    • LinkNet HT
    • Support for integrating The Mathworks®, Inc. MATLAB®/Simulink® generated code
    • Pattern 25: Cummins pattern for 60-2 6+1 with ability to sync on crank only. Contact Woodward for more information
    • Improved NetSim simulation of security model
    • Increased HMI_PT limit from 10,000 to 100,000 blocks

       What was new in 5.07-1 and 5.07-0

      

    • New pattern for PCMHD (pattern 24) with 60-2 crank, 6+1 Advanced CAM
    • Disables changing the LinkNet HT RDBK_EN field to address PID #16680 and #16685
    • Corrects PID #16774: Excessive flash memory consumption with EGAP
    • IC1100 functionality for the ECM3 platform
    • Support for the newly introduced LinkNet HT I/O Control Modules (RTD, TC, DIN, DOUT, and AI/AO) – Modules that will support control loops that are capable of operating at high temperature (100 deg C) and high vibration for skid mounted turbine and engine controls
    • Support for integrating The Mathworks®, Inc. MATLAB®/Simulink® generated code
    • Various other bug fixes and Help file improvements (see release notes)

    System Requirements:

    • Pentium® PC
    • 32 MB of RAM
    • Windows® 2000, XP, Vista, 7, 8, 10

    Installation Instructions:

    1. The first step in installing this software is to download the file from this page. This file is an installation program that will step you through the installation process.
    2. After downloading this file, run it and follow the instructions on the setup dialogs.

     

    Download:

    Item
    Name
    Version
    Size
    9927-2101
    GAP Programmer Coder 5.07
    B
    4.9 MB
     
    X
    Cookies help us improve your website experience.
    By using our website, you agree to our use of cookies.
    You can find more details in our Policy Statement.
    Ok